If your Spa is going over the maximun temperature limit of 104 Ferenheit degrees or over the set temperature, is most likely because the Pump has been running for extended periods of time, which might be due to 2 main reasons:


  1. Extended Filtration Cycles settings.
  2. A fault within the Control System.




1. Extended filtration cycles settings.


When exploring the different settings and options available thorugh the buttons on your topside, it may be easy to accidentally change the preset filtration cycles duration. The recommended duration is 2:00 hours which means the Spa will run the low speed of the pump for 2 hours every 12 hours


In order to confirm if this is the reason why the Spa is overheating, follow the steps below:


  1. Press either the Temperature Up or Down button. 
  2. While the temperature is flashing, press the Lights button. 
  3. Keep pressing Lights until you get to the FLTR setting on your display. 
  4. Press the Temperature Up or Down button until the display reads the current set duration (ex: "8:00" for EIGHT hours).
  5. If you found that duration was set higher than 2:00 hours, use the Temperature Down button to adjust it until you see 2:00 in the display.
  6. Press the Lights button to set your change. Please note that if you do not press the Lights button to set, the system will return to the previous setting after approximately 5 seconds and any changes will not be saved.
  7. After a few hours, you should notice that temperature on the display starts to decrease until it reaches the set temperature*.


*For additional details, please click here.


2A fault within the Control System.


If the filtration cycles were actually already set for 2:00 hours, the next step would be to confirm a possible fault within the control system of your Spa that allows the pump to runs the low speed constantly. 


Under normal operation, if you do a power reset your hot tub should not be running the low speed of the pump immediately after the power has been restarted.  Instead, the pump should be only running in low speed approximately 5 minutes after the power has been restarted OR if you press the Jets button to manually activate the pump (while you are getting the intial start up message: "run pumps purge air"). In both cases, the jets indicator light would be ON.

However, if you are getting water circulation in low speed immediately after you have restarted the power to the tub without pressing any buttons and the jets light remains OFF, that would indicate a fault with the Control System of your Spa.

To perform this test, follow the steps below:

1. Turn off the power to the spa (GFCI breaker).
2. Leave the power off for approximately 10 seconds.
3. Restore the power to the Spa.
4. Without pressing any buttons, observe the spa's start up procedure and advise if the following occurs as soon as power is restored to the spa:

  • Is there water circulation in the spa (is the spa circulating on low speed)? 
  • If there is actually water circulation within seconds after start up, is the "Jets" indicator light ON or OFF?


If you are able to provide a video and/or pictures of the results (showing the display as well as the inside of the tub), please send it to service@canadianspacompany.com for further assistance.


3. High ambient temperatures.


If none of the above situations apply to your case, extremely high ambient temperatures can also cause the Spa to overheat, especially if it is set under Ready Mode. Under this mode, the pump will run the low speed every 30 minutes approximately to check the water's temperature and to start heating if required. Please leave the Spa Cover off for a few hours and either reduce the set temperature or change the heating mode to Rest Mode to allow the pump to cool down.


To access to the heating modes, please follow the instructions below:

  1. Press either the Temperature Up or Down button.
  2. While the temperature is flashing, press the Lights button.
  3. Keep pressing Lights until you get to the MODE setting (you should see FLIP first then FLTR, followed by MODE)
  4. Press the Temperature Up or Down button to toggle between "SET READY" or "SET REST" which will be in smaller font at the bottom of the screen.
  5. Press the Lights button to set. Please note that if you do not press the Lights button to select an option, the display will revert to its original settings after 30 seconds and any changes you made will not be saved.


If you still require further assistance, please log a support ticket HERE.